[PATCH] Inline useless nested function mi_arena.
Carlos O'Donell
carlos@redhat.com
Thu Feb 27 06:28:00 GMT 2014
On 02/26/2014 04:49 PM, OndÅej BÃlka wrote:
> Hi,
>
> I noticed a minor simplification in malloc_info, that nested function
> mi_arena looks useless as it gets called at only one site and I do not
> have to rename its argument. The resulting patch is big due of
> reindenting but is simple in principle.
>
> Is there any deep reason to keep it?
Having the per-arena malloc_info actions broken out into a
logical block makes the malloc_info code easier to read
and understand.
> * malloc/malloc.c (malloc_info): Inline mi_arena.
Make it a real function please? That way the generated debug
information is better.
Cheers,
Carlos.
More information about the Libc-alpha
mailing list