[PATCH] Deduplicate resolv/nss_dns/dns-host.c
Mike Frysinger
vapier@gentoo.org
Fri Feb 14 17:25:00 GMT 2014
On Thursday, February 13, 2014 13:38:12 Ondřej Bílka wrote:
> Hi, when reviewing Andreas patch I noticed duplicated code. One way to
> improve that is jump to exit logic. A second possibility would be put
> gaih_getanswer into a else block. What do you prefer?
i don't mind either, but i think generally the preference is to avoid goto
when easily possible. so in this case, use the else.
-mike
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 836 bytes
Desc: This is a digitally signed message part.
URL: <http://sourceware.org/pipermail/libc-alpha/attachments/20140214/6a4405fb/attachment.sig>
More information about the Libc-alpha
mailing list