[PATCH] Remove nested function in elf/dl-lookup.c.

Carlos O'Donell carlos@redhat.com
Wed Feb 12 23:18:00 GMT 2014


On 02/12/2014 06:05 PM, Roland McGrath wrote:
> I completely disagree that this improves readability or maintainability in
> any way.  But I won't object.

Bug 8300 - no local symbol information within nested or nesting procedures
https://sourceware.org/bugzilla/show_bug.cgi?id=8300

Bug 53927 - wrong value for DW_AT_static_link 
http://gcc.gnu.org/bugzilla/show_bug.cgi?id=53927

If the above two bugs get fixed I'll consider having another discussion
about nested functions.

Cheers,
Carlos.
 



More information about the Libc-alpha mailing list