[PATCH 19/19] Define NOT_IN when building outside glibc.
Siddhesh Poyarekar
siddhesh.poyarekar@gmail.com
Fri Aug 22 14:24:00 GMT 2014
On 22 August 2014 19:20, Richard Henderson <rth@twiddle.net> wrote:
>> +#ifndef _LIBC
>> +# define NOT_IN(lib) (0)
>> +#endif
>
> I'm not especially convinced by the readability improvement of NOT_IN, and I'm
> particularly confused by a NOT_IN that defaults to false.
That's not the default definition; the default one is in
libc-symbols.h. That's a fallback definition when building outside
libc, but I'm thinking of getting rid of it because it will break
namespace tests for the headers.
Siddhesh
--
http://siddhesh.in
More information about the Libc-alpha
mailing list