[siddhesh/is_in_module] Fix SHLIB_COMPAT -Wundef warning
Siddhesh Poyarekar
siddhesh@redhat.com
Tue Aug 12 17:21:00 GMT 2014
Hi,
I've pushed the bits I've been working on for the SHLIB_COMPAT Wundef
warning to a private branch siddhesh/is_in_module. I need to do some
more verification (and write ChangeLogs!) before I post the changes as
a patchset. All patches barring one result in no changes[1] in
generated code, so I reckon they ought to be safe for inclusion if the
general idea is acceptable.
My approach with this patchset has been to replace the IS_IN_*,
NOT_IN_libc and IN_LIB macros with a single macro function
IS_IN_MODULE which is an accessor for the IN_MODULE macro, which is
always defined as MODULE_libc (actually MODULE_libc + MODULE_libs;
MODULE_libs is an indicator that the module is a core library,
i.e. libc, libm, librt, etc.) by default and explicitly overridden on
the commandline (using -UIN_MODULE and -DIN_MODULE=...). It also
seemed to also improve readability of the macros to me.
I'd love to get feedback from arch maintainers on this branch since I
have only verified x86_64 builds and nothing else.
Thanks,
Siddhesh
[1] I learnt that nscd_stat burns a timestamp into the code, resulting
in a change in code with every build. That change crops up in
every build.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 473 bytes
Desc: not available
URL: <http://sourceware.org/pipermail/libc-alpha/attachments/20140812/c2575fa1/attachment.sig>
More information about the Libc-alpha
mailing list