[PATCH v1.1] Deduplicate resolv/nss_dns/dns-host.c
Mike Frysinger
vapier@gentoo.org
Sat Aug 2 13:16:00 GMT 2014
On Fri 04 Jul 2014 10:41:25 Allan McRae wrote:
> On 15/02/14 21:39, Ondřej Bílka wrote:
> > On Fri, Feb 14, 2014 at 12:25:51PM -0500, Mike Frysinger wrote:
> >> On Thursday, February 13, 2014 13:38:12 Ondřej Bílka wrote:
> >>> Hi, when reviewing Andreas patch I noticed duplicated code. One way to
> >>> improve that is jump to exit logic. A second possibility would be put
> >>>
> >>> gaih_getanswer into a else block. What do you prefer?
> >>
> >> i don't mind either, but i think generally the preference is to avoid
> >> goto
> >> when easily possible. so in this case, use the else.
> >> -mike
> >
> > OK, patch for this is following. It should cover one extra possibility
> > when
> > __libc_res_nsearch fails and allocates separate buffer.
> >
> > * resolv/nss_dns/dns-host.c (_nss_dns_gethostbyname4_r): Remove
> > duplicate code
>
> Ondřej: This was committed without a ChangeLog entry. Can you insert
> one in the appropriate place.
looks like Allan did this for you ~3 weeks later. i wonder why he had to.
-mike
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 819 bytes
Desc: This is a digitally signed message part.
URL: <http://sourceware.org/pipermail/libc-alpha/attachments/20140802/dc5895f5/attachment.sig>
More information about the Libc-alpha
mailing list