[RFC][PATCH] (Elision) Rename retry_try_xbegin to try_xbegin
Dominik Vogt
vogt@linux.vnet.ibm.com
Wed Sep 18 11:36:00 GMT 2013
The attached patch renames retry_try_xbegin in the elision_config
structure to try_xbegin and fixes the source code documentation.
It is actually not the number of _re_tries but the total number of
attempts using elision before using the lock. The docuementation
suggested that (with the default values) one attempt plus three
retries would be made while in reality it were only three attempts
in total.
Ciao
Dominik ^_^ ^_^
--
Dominik Vogt
IBM Germany
-------------- next part --------------
A non-text attachment was scrubbed...
Name: 0001-x86-Rename-retry_try_xbegin-to-try_xbegin-which-is-m.patch
Type: text/x-diff
Size: 2325 bytes
Desc: not available
URL: <http://sourceware.org/pipermail/libc-alpha/attachments/20130918/6b2c6f2f/attachment.bin>
-------------- next part --------------
2013-09-18 Dominik Vogt <vogt@linux.vnet.ibm.com>
* sysdeps/unix/sysv/linux/x86/elision-lock.c (__lll_lock_elision):
* sysdeps/unix/sysv/linux/x86/elision-conf.c:
* sysdeps/unix/sysv/linux/x86/elision-conf.h (struct elision_config):
Rename elision_config.retry_try_xbegin to try_xbegin
More information about the Libc-alpha
mailing list