[PATCH] benchtests: Rename argument to TIMING_INIT macro.
Siddhesh Poyarekar
siddhesh@redhat.com
Wed Sep 11 12:45:00 GMT 2013
On Wed, Sep 11, 2013 at 01:27:51PM +0100, Will Newton wrote:
>
> The TIMING_INIT macro currently sets the number of loop iterations
> to 1000, which limits usefulness. Make the argument a clock
> resolution value and multiply by 1000 in bench-skeleton.c instead
> to allow easier reuse.
>
> ChangeLog:
>
> 2013-09-11 Will Newton <will.newton@linaro.org>
>
> * benchtests/bench-timing.h: Rename iters parameter
> to res and remove hardcoded 1000 value.
> * benchtests/bench-skeleton.c: Pass res parameter to
> TIMING_INIT and multiply by 1000.
ChangeLog should be:
* benchtest/bench-timing.h (TIMING_INIT): Rename parameter to
RES. Remove hardcoded 1000 value.
* benchtests/bench-skeleton.c (main): Pass RES parameter to
TIMING_INIT and multiply result by 1000.
The change itself is fine.
Thanks,
Siddhesh
More information about the Libc-alpha
mailing list