[PATCH][BZ #11157][v2] Rename uses of '__block' in installed header files
Carlos O'Donell
carlos@redhat.com
Sat Nov 23 16:44:00 GMT 2013
On 11/21/2013 02:52 PM, Meador Inge wrote:
> Hi All,
>
> As detailed in PR11157, the use of '__block' is known to interfere with
> keywords in some environments, such as the Clang -fblocks extension.
> Recently a similar issue was raised concerning the use of '__unused'
> and a '__glibc' prefix was proposed to create a glibc implementation
> namespace for these sorts of issues [1]. This patches takes that approach.
>
> I performed the usual 'make check' testing, verified that issues compiling
> applications with glibc headers using 'clang -fblocks' are gone, and ensured
> that there are no code generation differences as a result of the change.
>
> Note that this is also on Joseph's glibc/EGLIBC differences list [2].
>
> OK?
>
> [1] https://sourceware.org/ml/libc-alpha/2012-02/msg00047.html
> [2] http://lists.debian.org/debian-glibc/2013/11/msg00020.html
>
> 2013-11-21 Meador Inge <meadori@codesourcery.com>
>
> [BZ #11157]
> * crypt/crypt.h (encrypt): Use __glibc_block instead of __block.
> (encrypt_r): Likewise.
> * malloc/obstack.h (obstack_free): Likewise.
> * posix/unistd.h (encrypt): Likewise.
Looks good to me. Checked in. Bug closed.
Updated consensus document to say that anyone can make changes that
rename __block to __glibc_block or __unused to __glibc_reserved.
commit 84ae135d3282dc362bed0a5c9a575319ef336884
Author: Meador Inge <meadori@codesourcery.com>
Date: Thu Nov 21 16:57:37 2013 -0500
Use __glibc_block in public headers.
As detailed in PR11157, the use of '__block' is known to interfere
with keywords in some environments, such as the Clang -fblocks extension.
Recently a similar issue was raised concerning the use of '__unused'
and a '__glibc' prefix was proposed to create a glibc implementation
namespace for these sorts of issues [1]. This patches takes that
approach.
[1] https://sourceware.org/ml/libc-alpha/2012-02/msg00047.html
[2] http://lists.debian.org/debian-glibc/2013/11/msg00020.html
Cheers,
Carlos.
More information about the Libc-alpha
mailing list