[PATCH 1/9] Add vectorized getenv for glibc use

Siddhesh Poyarekar siddhesh@redhat.com
Mon May 13 05:52:00 GMT 2013


On Sat, May 11, 2013 at 12:32:40AM +0200, Andi Kleen wrote:
> On Thu, May 09, 2013 at 03:03:13PM +0530, Siddhesh Poyarekar wrote:
> > > +    _dl_glibc_var;
> > > +    __glibc_var_init;
> > 
> > These should be sorted.
> 
> FWIW the existing entries are not sorted.  I moved my new ones.

Then they ought to be sorted and pushed as an obvious change before
your patch.

> > We might want to enforce namespaces from the beginning here.  How
> > about GLIBC_PTHREAD_MUTEX_TYPE or similar?  I don't want to bikeshed
> > on the actual name; I'm fine as long as a good namespace convention is
> > established.
> 
> The environment variables are called GLIBC_MUTEX and GLIBC_RWLOCK
> I don't think it makes sense to call the internal names anything
> else.

Sorry, I guess I wasn't clear enough.  I meant namespaces for the
environment variables since they are good candidates for inclusion
into generic tunables.

Siddhesh



More information about the Libc-alpha mailing list