[PATCH] Better distinguish between NaN/qNaN/sNaN.

Andreas Jaeger aj@suse.com
Tue Mar 5 21:08:00 GMT 2013


On 03/05/2013 08:31 PM, Thomas Schwinge wrote:
> In preparation for adding tests with sNaN inputs later on.
>
> 	* math/basic-test.c (TEST_FUNC, TEST_TRUNC): Rename NaN_var to
> 	qNaN_var.  Fix a few strings, too.
> 	* math/libm-test.inc (nan_value): Rename to qnan_value.
> 	* math/gen-libm-test.pl (%beautify): Adjust to that.
> 	* math/bits/mathcalls.h (nan): Refer to qNaN instead of NaN.
> 	* math/test-misc.c (main): Likewise.
> 	* sysdeps/ieee754/bits/nan.h (__nan_bytes, __nan_union): Rename
> 	to __qnan_bytes, and __qnan_union, respectively.
> 	* ports/sysdeps/mips/bits/nan.h (__nan_bytes, __nan_union):
> 	Likewise.
> 	* stdio-common/tstdiomisc.c (nanval, lnanval): Rename to qnanval,
> 	and lqnanval, respectively.
> 	* sysdeps/powerpc/bits/fenv.h: Fix usage of NaN/qNaN/sNaN.
> 	* sysdeps/powerpc/fpu/fenv_libc.h: Likewise.
> 	* sysdeps/powerpc/fpu/test-powerpc-snan.c (TEST_FUNC): Likewise,
> 	and rename NaN_var to qNaN_var, and SNaN_var to sNaN_var.

this is fine,

Andreas
-- 
  Andreas Jaeger aj@{suse.com,opensuse.org} Twitter/Identica: jaegerandi
   SUSE LINUX Products GmbH, Maxfeldstr. 5, 90409 Nürnberg, Germany
    GF: Jeff Hawn,Jennifer Guild,Felix Imendörffer,HRB16746 (AG Nürnberg)
     GPG fingerprint = 93A3 365E CE47 B889 DF7F  FED1 389A 563C C272 A126



More information about the Libc-alpha mailing list