[PATCH] Drop PER_THREAD conditionals.
Ondřej Bílka
neleai@seznam.cz
Sun Dec 8 12:22:00 GMT 2013
On Fri, Dec 06, 2013 at 09:12:09AM +0530, Siddhesh Poyarekar wrote:
> On Fri, Dec 06, 2013 at 01:04:02AM +0100, OndÅej BÃlka wrote:
> > Hi, when I looked at malloc code I wondered on what conditions
> > we compile malloc with PER_THREAD. As in Makefile we have PER_THREAD
> > enabled unconditionally. There may be reason to keep a PER_THREAD but
> > for simplicity of implementation I would just remove it.
> >
> > Could somebody shed light on this.
> >
>
> As a Fedora maintainer I agree with removing [!PER_THREAD] bits since
> we don't change that define and it makes the code easier to read. It
> made sense to keep it when the PER_THREAD bits were new, to test bugs
> against the older implementation for comparison, but I believe the
> PER_THREAD bits are mature enough now to get rid of the alternative.
>
> Other distribution maintainers should also pitch in with an opinion on
> this since I don't know if anyone actually overrides that define in
> their package.
>
> I don't think the ChangeLog is correct, but the patch itself looks OK.
>
So how should changelog look like?
More information about the Libc-alpha
mailing list