> So, what about renaming it to ASM_SIZE, remove definitions in sysdep.h > headers and moving the definion of ASM_SIZE into say libc-symbols.h? The name seems odd for something that you only use in assembly code. I'd go with SYMBOL_SIZE or SIZED_SYMBOL. Putting it in libc-symbols.h is fine.