> I don't think it is worth the complexity since there is a check > for __WORDSIZE already. I consider it less complexity than repeating a function definition. It also will make for a simple and obvious change if we later conclude that just using uint64_t directly is an OK thing to do. Thanks, Roland