[PATCH] Link dynamic tests with newly built glibc

Joseph S. Myers joseph@codesourcery.com
Wed Oct 10 14:33:00 GMT 2012


On Tue, 9 Oct 2012, H.J. Lu wrote:

> Here is the updated patch with test-program-prefix/test-program-cmd.
> OK to install?

There are some places where the makefiles pass makefile variables to shell 
scripts that are no longer used.  For example, grp/tst_fgetgrent.sh sets 
variables elf_objpfx and rtld_installed_name from the command line, but no 
longer uses them after your patch (and also sets a no-longer-used variable 
library_path).  In such cases, I think you should remove the parameters 
from the command line passed by the makefile, and remove the variables 
from the script.

In other cases, variables in the shell scripts are set with names that 
correspond to the name of the relevant makefile variable, but you've 
changed the makefile variable passed.  For example, 
localedata/sort-test.sh sets a variable run_program_prefix, but now 
$(test-program-prefix) is being passed.  In such a case, I think the shell 
script variable should be renamed test_program_prefix to reflect the 
change in semantics.

-- 
Joseph S. Myers
joseph@codesourcery.com



More information about the Libc-alpha mailing list