[RFC/PATCH] epoll: replace EPOLL_CTL_DISABLE with EPOLL_CTL_POKE
Eric Wong
normalperson@yhbt.net
Tue Nov 6 21:59:00 GMT 2012
Christof Meerwald <cmeerw@cmeerw.org> wrote:
> On Fri, 2 Nov 2012 04:13:12 +0000, Eric Wong wrote:
> [...]
> > EPOLL_CTL_POKE may be used to force an item into the epoll
> > ready list. Instead of disabling an item asynchronously
> > via EPOLL_CTL_DISABLE, this forces the threads calling
> > epoll_wait() to handle the item in its normal loop.
>
> That was my initial suggestion as well - see
> https://lkml.org/lkml/2012/6/19/358
Thanks, missed that the first time around. Perhaps TRIGGER is a
better name than POKE :x
I'm hoping Paton has a chance to look at my implementation and
comment on it.
More information about the Libc-alpha
mailing list