PATCH: Add x32 support to STACK_CHK_GUARD

Roland McGrath roland@hack.frob.com
Fri May 11 21:01:00 GMT 2012


We already support sysdeps stackguard-macros.h files for ports and all
those machine-specific cases ought to be moved out to new sysdeps files.
It's not important that this cleanup be done right away.  But for a new
case, just add a new sysdeps file instead.

While we're getting cleaner, it really would be better to use a %P0 with
"i" (offsetof (tcbhead_t, stack_guard)) rather than the magic constant.

In fact, AFAICT if you do that and make the insn just "mov", then a single
x86_64 file would dtrt for both x86_64 and x32.


Thanks,
Roland



More information about the Libc-alpha mailing list