That is probably fine. But it really seems to me that we should not be using vague types like "long" and "long long", when we mean very specific things. It's better to use uint64_t or uintptr_t, etc., as appropriate to what exactly it is you mean in a particular use. Thanks, Roland