PATCH: Add LP_SIZE, OP_LP, ASM_ADDR and RXX_LP to x86_64/sysdep.h
Roland McGrath
roland@hack.frob.com
Fri Mar 16 23:03:00 GMT 2012
It's hard to evaluate the wisdom of particular macro choices without
seeing all the cases where they're used.
Instead of the several MOVE_LP et al, we could just have a single macro:
#define LP(insn) insn##q
(could be a different name). For parity, it seems appropriate to define
that for !__ASSEMBLER__ too, in case they are needed in asm().
Thanks,
Roland
More information about the Libc-alpha
mailing list