Cross-rpcgen patch, version 4

Roland McGrath roland@hack.frob.com
Wed Apr 25 21:47:00 GMT 2012


> +build-compile-command.c = $(BUILD_CC) $($(basename $(<F))-CFLAGS) \
> +			  $(ALL_BUILD_CFLAGS) $< $(OUTPUT_OPTION)

A variable of this name should include -c, since it's parallel to
compile-command.c.  If it's not going to include the dependency-generation
flags, then it should be called build-compile.c instead, since it's really
parallel to compile.c and not to compile-command.c.

If it's not prohibitively hairy, making it do the automatic dependencies
stuff would be nice.


Thanks,
Roland



More information about the Libc-alpha mailing list