> how about changing "others" to "programs" ? it's certainly clearer what it > means and ties better with $(build-programs) ... It seems less likely the patch will be small and surely correct in getting all uses.