[PATCH] Unwinding CFI for x86_64 signal frame (__restore_rt)

Daniel Jacobowitz drow@false.org
Mon Nov 27 21:46:00 GMT 2006


On Mon, Nov 27, 2006 at 12:43:39PM +0100, Jakub Jelinek wrote:
> is possible, but way too unreadable).  I plan to change fix
> that on the gas side soon, but for the time being I'd say
> you'd have much more readable unwind info if you just coded
> by hand a (commented) .eh_frame section, after all, .cfi_*
> directives don't help you much here, because all you want
> is cover the 2 instructions including 1 byte before them.
> With an open coded .eh_frame for the sigreturn pad, you don't
> need configure checks for .cfi_signal_frame, you just use
> S at the end of the augmentation.

FYI, I did this and was told not to do it that way.

  http://sourceware.org/ml/gdb/2006-07/msg00131.html

Followup discussion in the August archives too.  My plan was to use
macros to expand uleb128 in the few places it was needed for the
expressions.

-- 
Daniel Jacobowitz
CodeSourcery



More information about the Libc-alpha mailing list