[PATCH] Update sysdeps/unix/sysv/linux/*/bits/mman.h

Roland McGrath roland@redhat.com
Sun Mar 13 09:37:00 GMT 2005


> 	* sysdeps/unix/sysv/linux/mips/bits/mman.h: Fix MAP_RENAME value.
> 	Add misc flags.
> 	* sysdeps/unix/sysv/linux/powerpc/bits/mman.h: Define MAP_RENAME.

All macros added should be named.  The named one and the unnamed others are
all no-ops not actually used for anything in Linux.  MAP_RENAME is not even
documented nor suggested to be useful on Solaris.  So I just don't see the
sense in adding any of these.

> 	* sysdeps/unix/sysv/linux/sh/bits/mman.h: Define MAP_POPULATE and
> 	MAP_NONBLOCK.
> 	* sysdeps/unix/sysv/linux/sparc/bits/mman.h: Define MAP_POPULATE and
> 	MAP_NONBLOCK.  Update MAP_GROWSDOWN value.

These I put in.


Thanks,
Roland



More information about the Libc-alpha mailing list