sysdeps/i386/i486/bits/string.h: describing memory access question
Denis Zaitsev
zzz@cd-club.ru
Mon Jan 13 04:56:00 GMT 2003
So, just everyhere we have (for now) something like
"m" ( *(struct { char __x[0xfffffff]; } *)__str)
in the input parameters list. The question is: why 0xfffffff is used?
Would 0x7fffffff be better? As it describes all the usable memory,
not just 1/8 part of it.
And would it be better to use some macros for this, like:
"m" (*(ALL_MEM*)__str)
along with, say:
"m" (*(PART_MEM(__len)*)__mem)
for __mem[__len] parameters. It seems to be more readable and more
convinient and more etc. I would like to implement this, if the idea
in general is sane.
More information about the Libc-alpha
mailing list