[open-source] Re: Wish for 2002 ...

Linus Torvalds torvalds@transmeta.com
Fri Jan 11 12:09:00 GMT 2002


On Fri, 11 Jan 2002, Linus Torvalds wrote:
>
> 	static char *strdup2(const char *s1, const char *s2)

What kind of stupid nincompoop would first complain about other peoples
code, and then select a silly name like that? "strdup2()"? Hello, clutz!
It's not only non-sensical, but it's not really even portable because of
the "strxxx()" format.

Call it "concat_string()" instead, dum-dum.

	Linus "can keep a flame-war going by himself" Torvalds



More information about the Libc-alpha mailing list