proposed support for lazy values

Charles Turner chturne@gmail.com
Mon Jun 6 15:45:00 GMT 2011


On 06/06/2011 15:28, Jamison Hope wrote:
>
> I would argue that the print at line 4 should say something like 
> "#<promise - force threw a java.lang.Exception>" instead. How about 
> the attached update to your patch?
<Warning: off-topic>

Certainly a better error message, but I have a concern. Back when I was 
fixing up some error messages, I noticed an aweful lot of ad-hoc errors 
being directly written to an output buffer, just like this patch. It 
seems to me that all errors should be encapsulated by a common error 
class. This would mean the messages would be consistent and less 
confusing. It would also be easier to extend such error classes to 
things like the Swing REPL or WebSocket REPL's, etc to do more 
interesting formatting. It's going to be a chore going through and 
abstracting such messages, but I think it would be worthwhile.

Charles.




More information about the Kawa mailing list