New Kawa "path" functions

Robert D. Skeels rdsathene@sbcglobal.net
Thu Jan 11 07:13:00 GMT 2007


On Jan 10, 2007, at 19:33, Per Bothner wrote:

> In some cases I'm not sure I found the right name for the functions.
> Even the type name "path" and "filepath" are none-ideal.  For
> example the word "resource" might work better than "path".  Should
> "path-file" be "path-path" - or something else?  If you have any
> opinions or suggestions, I'd prefer to receive them before 1.9
> goes out!


How about path-file-hierarchy (in keeping with rfc3986 section 3.3)?


A question. I am tired so if this doesn't make sense please forgive.  
If we have file: as a scheme like http:, then wouldn't FilePath be  
another instance (ie. English, not OOP) of a URIPath?



More information about the Kawa mailing list