GSL on Cygwin

Cheng Xing cheng.linux@gmail.com
Tue Nov 21 17:50:00 GMT 2006


Hi,

I am a windows user running gsl on cygwin. For some reason, I
reinstalled cygwin last week, then I find all of my c++ codes calling
gsl pass the compiler but the executes do not work properly which work
perfectly before the reinstallation. To investigate, I complied the
example of ODE solver from gsl manual, it passed. I ran the execute ,
nothing happened then I was on the command line again. For my other
codes without calling gsl, everything works perfectly.

I tried gcc 3.4.4.1 and 3.4.4.2 with gsl 1.8.1 and 1.7.1, but the
problem is still there.

I am pasting the screen here, run.cpp is the example from GSL manual.

$ C++ $(gsl-config --cflags) run.cpp $(gsl-config --libs) -g -o r.exe
Info: resolving _gsl_odev_step_rk8pd by linking to _imp_gsl_odeiv_step_rk8pd
(auto-import)

$gdb
GNU gdb 6.5.50.20060706-cvs (cygwin-special)
Copyright (c) 2006 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.Type "show warranty" for details.
This GDB was configured as "i686-pc-cygwin"...
(gdb) run
Starting program: /cygdrive/c/Documents and Settings/cxing/project/ring
/multi/te
st/r.exe
gdb: unknown target exception 0xc0000135 at 0x7c964ed1

Program received signal ?, Unknown signal.

Program exited with code 030000000465
You can't do that without a process to debug.


Anyone could kindly give me some suggestion?

Best regards,
Cheng



More information about the Gsl-discuss mailing list