Version Problem

Brian Gough bjg@network-theory.co.uk
Mon Feb 9 18:17:00 GMT 2004


Carlo Ferrigno writes: Upgrading from version 1.3 to 1.4 I noticed the
 > definition of physical constant has changed.
 > 1) the file gsl_const.h does not include the right files and gives
 > an error 
 > 2) the constant are named in a different way. This does
 > not allow to compile a programme built for 1.3 with gsl 1.4 and
 > vice versa.  Do you have any suggestion to overcome the problem
 > without rewriting the code, for example with a preprocessing set of
 > commands ?
 > 

I messed up gsl_const when I made the 1.4 release (I'm sorry).  It is
broken.

If you have both versions installed you can try something like this,

   gcc -I/opt/gsl-1.4/include -I/opt/gsl-1.3/include ....

or use the C_INCLUDE_PATH environment variable.

I will try to fix it all in 1.5, so it is smoothly backwards compatible.

An alternative is to ship the appropriate files (e.g. gsl_mks.h and
gsl_cgs.h) with your source in such a way that they are included
(e.g. in a gsl/ subdirectory).  Note that the cgs electrical constants
in 1.3 were incorrect (missing factor of 4pi)

-- 
Brian Gough



More information about the Gsl-discuss mailing list