Compiling GSL 1.3 on IRIX 6.5

Brian Gough brian.gough@network-theory.co.uk
Sat Feb 1 18:42:00 GMT 2003


Greg Perkins writes:
 > (cd .libs && rm -f libgslsys.la && ln -s ../libgslsys.la
 > libgslsys.la) Making all in test
 >        /bin/sh ../libtool --mode=compile gcc -DHAVE_CONFIG_H
 >        -I. -I.
 > -I..  -g -O2 -c results.c
 > mkdir .libs gcc -DHAVE_CONFIG_H -I. -I. -I.. -g -O2 -c results.c
 > -DPIC -o .libs/results.lo In file included from results.c:24:
 > /usr/gnu/lib/gcc-lib/mips-sgi-irix6-o32/2.8.1/include/stdlib.h:207:
 > conflicting types for `initstate' /usr/include/math.h:731: previous
 > declaration of `initstate' *** Error code 1 (bu21)

Thanks for the bug report.

A google search for 'irix initstate' suggests it is a general gcc
problem on that platform.

 > I have also tried specifying the standard MipsPro C compiler (cc)
 > (version 7.3.1.3m) , using setenv CC "cc" ./configure make however
 > the configuration file continues to use the gcc compiler. I've
 > tried a couple of other methods to force the use of cc all to no
 > avail.
 > 
 > Does anybody have any suggestions on how to resolve these issues???
 > 

It should work.  If you still have problems please send a complete
transcript of the commands and corresponding output from configure,
from a clean start of a newly unpacked tarfile.

Brian




More information about the Gsl-discuss mailing list