trouble with autogen.sh from cvs
Brian Gough
bjg@network-theory.co.uk
Fri Jan 31 16:05:00 GMT 2003
Achim Gädke wrote:
> I've adapted the configure.in to the new version. configure.in is now
> called configure.ac, so you should rename configure.in.
>
> Trouble was caused by nested macro calls:
>
> AC_TRY_COMPILE([#define hypot /* */
> #include <math.h>],[{}],[],AC_CHECK_FUNCS(hypot))
>
> These have to be quoted
>
> AC_TRY_COMPILE([#define hypot /* */
> #include <math.h>],[{}],[],[AC_CHECK_FUNCS(hypot)])
>
> as stated in the autoconf->Programming in M4->M4 Quotation->Quotation
> and Nested Macros
> It took me 4 hours to get to that point. :-(
>
Thanks for tracking down the problem. I will fix the quoting and have
another look at the new version of autoconf.
Brian
More information about the Gsl-discuss
mailing list