Compiling GSL 1.3 on IRIX 6.5

Greg Perkins perkinsg@materials.unsw.edu.au
Thu Jan 30 06:57:00 GMT 2003


Hi

I've downloaded gsl.1.3.tar.gz and am trying to compile it on IRIX 6.5.

Using

./configure
make

I get the following output:

.....

(cd .libs && rm -f libgslsys.la && ln -s ../libgslsys.la libgslsys.la)
Making all in test
       /bin/sh ../libtool --mode=compile gcc -DHAVE_CONFIG_H -I. -I. 
-I..     -g -O2 -c results.c
mkdir .libs
gcc -DHAVE_CONFIG_H -I. -I. -I.. -g -O2 -c results.c  -DPIC -o 
.libs/results.lo
In file included from results.c:24:
/usr/gnu/lib/gcc-lib/mips-sgi-irix6-o32/2.8.1/include/stdlib.h:207: 
conflicting types for `initstate'
/usr/include/math.h:731: previous declaration of `initstate'
*** Error code 1 (bu21)
*** Error code 1 (bu21)
*** Error code 1 (bu21)


I have gcc version 2.8.1

I have also tried specifying the standard MipsPro C compiler (cc) 
(version 7.3.1.3m) , using

setenv CC "cc"
./configure
make

however the configuration file continues to use the gcc compiler. I've 
tried a couple of other methods to force the use of cc all to no avail.

Does anybody have any suggestions on how to resolve these issues???

Thanks

Greg Perkins




More information about the Gsl-discuss mailing list