gsl 1.3 and MAC OSX

Attilio Rivoldini rivoldini@oma.be
Wed Jan 15 10:34:00 GMT 2003


Hi,

Here are some issues I got building gsl 1.3 on mac os x 10.2.3 with gcc 
3.1:

1)

./configure --disable-shared

gsl 1.3 compiles and all checks pass.

2)

Now doing as suggested in the INSTALL file, for building shared libs:

  1. Get the fink packaging tool (http://fink.sourceforge.net)
   2, Install fink's libtool14, automake, autoconf25.
   3. Regenerate GSL's configuration using ./autogen.sh in the
      top-level directory.
   4. ./configure, make

Fails on ./configure with the following output:

./autogen.sh
Makefile.am: installing `./depcomp'
configure.in:23: warning: AC_ARG_PROGRAM invoked multiple times

./configure
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
/Volumes/Users/tilio/work/soft/gsl-1.3: 
/Volumes/Users/tilio/work/soft/gsl-1.3: is a directory
configure: WARNING: `missing' script is too old or missing
checking for gawk... no
checking for mawk... no
checking for nawk... no
checking for awk... awk
checking whether make sets ${MAKE}... yes
checking whether to enable maintainer-specific portions of Makefiles... 
no
checking whether make sets ${MAKE}... (cached) yes
checking build system type... powerpc-apple-darwin6.3
checking host system type... powerpc-apple-darwin6.3
checking for gcc... gcc
checking for C compiler default output... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ANSI C... none needed
checking for style of include used by make... GNU
checking dependency style of gcc... gcc
checking how to run the C preprocessor... gcc -E
checking for a BSD-compatible install... /usr/bin/install -c
checking whether ln -s works... yes
checking for ranlib... ranlib
checking for ar... ar
checking for ld used by GCC... /usr/bin/ld
checking if the linker (/usr/bin/ld) is GNU ld... no
checking for /usr/bin/ld option to reload object files... -r
checking for BSD-compatible nm... /usr/bin/nm -p
checking how to recognise dependant libraries... file_magic Mach-O 
dynamically linked shared library
checking command to parse /usr/bin/nm -p output... ok
checking for egrep... grep -E
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking dlfcn.h usability... no
checking dlfcn.h presence... no
checking for dlfcn.h... no
checking for ranlib... (cached) ranlib
checking for strip... strip
checking for objdir... .libs
checking for gcc option to produce PIC... -fno-common
checking if gcc PIC flag -fno-common works... yes
checking if gcc static flag -static works... no
checking if gcc supports -c -o file.o... yes
checking if gcc supports -c -o file.lo... yes
checking if gcc supports -fno-rtti -fno-exceptions... yes
checking whether the linker (/usr/bin/ld) supports shared libraries... 
yes
checking how to hardcode library paths into programs... unsupported
checking whether stripping libraries is possible... no
checking dynamic linker characteristics... darwin6.3 dyld
checking if libtool supports shared libraries... yes
checking whether to build shared libraries... yes
checking whether to build static libraries... yes
creating libtool
checking for size_t... yes
checking for an ANSI C-conforming const... yes
checking for inline... inline
checking for extern inline... yes
checking for library containing cos... none required
./configure: line 11409: syntax error: unexpected end of file

Why does it fail?

3)

Also I tried to link gsl against Apples veclib framework instead of 
using gsl's cblas. When I run the cblas test's I get the
following error:

PASS: csyrk(case 1585) imag (0.339074 observed vs 0.339074 expected)
Trans must be 111, 112 or 113, but is set to 113Parameter 3 to routine 
cblas_csyrk was incorrect
Mac OS BLAS parameter error in cblas_csyrk, parameter #0, 
(unavailable), is 0


Now I was told that this the way cblas should behave because:

> Behaves correctly by rejecting the bogus call to CSYRK (but does give a
> confusing error message.)
>
> Page 184 of the following reference states: "For complex symmeteric
> matrices, TRANS='H' is not allowed." (In the CBlas the enum value 113
> denotes TRANS 'H'.)

>  LAPACK Users' Guide, Third Edition.
>         @BOOK{laug,
>             AUTHOR = {Anderson, E. and Bai, Z. and Bischof, C. and
>                         Blackford, S. and Demmel, J. and Dongarra, J. 
> and
>                         Du Croz, J. and Greenbaum, A. and Hammarling, 
> S. and
>                         McKenney, A. and Sorensen, D.},
>             TITLE = {{LAPACK} Users' Guide},
>             EDITION = {Third},
>             PUBLISHER = {Society for Industrial and Applied 
> Mathematics},
>             YEAR = {1999},
>             ADDRESS = {Philadelphia, PA},
>             ISBN = {0-89871-447-8 (paperback)} }
>

Needless to say that all the other cblas checks, beside those with 
csyrk did compile and pass. So cblas test suite error
or problem with Apples veclib?

4)
>> Finally a little request. I'm would be very glad to see a PDF
>> version of reference manual.

> Ghostscript's ps2pdf will do the conversion from the PS file, I think
> it is available for the Mac.

I agree but the pdf one gets from ps2pdf contains bitmap fonts which 
are not very readable on screen.

Is there a way to build the reference manual from the files in the doc 
folder? I tried the following but it didn't work:
(all the tex and latex stuff is of course installed)

make dvi
TEXINPUTS=".@PATH_SEPARATOR@$TEXINPUTS" \
MAKEINFO='makeinfo   -I .' \
texi2dvi gsl-ref.texi
/usr/bin/texi2dvi: tex: command not found
/usr/bin/texi2dvi: tex exited with bad status, quitting.
/usr/bin/texi2dvi: see gsl-ref.log for errors.
make: *** [gsl-ref.dvi] Error 1


Thanks,

Tilio



More information about the Gsl-discuss mailing list