Backport 037e8112b97 for the 10.x branch

Emil Velikov emil.l.velikov@gmail.com
Tue May 18 10:35:27 GMT 2021


Hi Joel,

Thanks for the prompt reply

On Mon, 17 May 2021 at 17:21, Joel Brobecker <brobecke@adacore.com> wrote:
>
> Hi Emil,
>
> On Sun, May 16, 2021 at 03:00:06PM +0100, Emil Velikov wrote:
> > Greetings Joel, all,
> >
> > I'd like to nominate a patch for the 10.x branch, in particular
> > 037e8112b97 ("[gdb/server] Don't overwrite fs/gs_base with -m32").
> > Since I just missed 10.2 - it would be great if we can have it in the
> > next bugfix release.
>
> We are not planning on doing another 10.x release, so would that
> still be useful for you to do?
>
Yes, it would.

> Note that we're started the process of preparing for the GDB 11.1
> release. It's really hard to predict how long it's going to take
> before we release, considering that we are a volunteer project,
> but I'm hoping a couple of months.
>
Realising that I'm pushing my luck, I would warmly encourage you to do
another 10.x release.
Partially due to the severity of the bug - anything built with -m32 is
affected - and partially due to how wide-spread the 10.x series is.

>From a casual look at repology [1] the following distributions are
affected and a bunch of them will be "stuck" with the 10.x series.
Thus I do think it will be of great benefit in having another 10.x
with said fix - even if only this patch is included.

List of distributions using GDB 10.x alongside 5.9+ kernel - Alpine,
Arch, Debian testing, Fedora 33&34, openSUSE Leap 15.x, Ubuntu 21.04
... and their respective derivatives.

Thanks for your time and dedication improving GDB.
-Emil

[1] https://repology.org/project/gdb/versions


More information about the Gdb mailing list