Proposal to remove Python 2 support

Tom Tromey tom@tromey.com
Fri Sep 18 16:55:38 GMT 2020


Pedro> Dropping Python 2 support is going to be an issue for us, given
Pedro> we will still have a couple years more of DTS releases for RHEL
Pedro> 7, which is Python 2.7 based.

>> RHEL 7 comes with Python 3.6 as well.

I think the issue must be that gdb is built against Python 2 on RHEL 7.

Does anyone know if there are other distros with LTS releases that do
this?  I guess it makes sense to hold off for those; at least major
distros anyway.

Tom


More information about the Gdb mailing list