gdb 9.2 won't build

Doug Abbott doug@intellimetrix.us
Tue Sep 8 19:54:22 GMT 2020


Thanks for the hint Joel. I had to install the ncurses-devel and texinfo 
packages and then it built.

Doug

On 9/8/2020 11:10 AM, Joel Brobecker wrote:
>> I'm trying to build gdb 9.2 natively on a Linux x86_64 machine, a guest
>> running under VirtualBox on Windows 10. The linker is throwing a number of
>> "undefined reference" symbols like tputs and tgetflag which appear to have
>> something to do with ncurses and/or termcap.
>>
>> I tried the configure command shown in the wiki under building natively,
>> adding --disable-tui because that fixed a different problem. I'm guessing
>> I'm missing a library, but which one?
>>
>> The reason I'm going through this exercise is that gdb 7.6 that comes with
>> CentOS 7 won't read the python support functions for KGDB. It complains
>> about "missing attribute COMPLETE_EXPRESSION".
> Try maybe forcing the use of ncuses by configuring GDB --with-curses?
> You might get an error if you don't have the ncurses headers installed;
> if that happens, install the ncurses dev package, and then try again.
>

-- 
Doug Abbott
Principal Consultant, Intellimetrix
Linux for the Real World
575-590-2788

www.intellimetrix.us




More information about the Gdb mailing list