GDB 8.3.1 gdbserver linker error: needs -lrt

Eli Zaretskii eliz@gnu.org
Fri Jan 31 07:44:00 GMT 2020


> From: Simon Marchi <simark@simark.ca>
> Date: Thu, 30 Jan 2020 17:49:59 -0500
> 
> >> That would work around the problem, but if you want to fix it for
> >> good, for all users in the same situation, then it would probably
> >> require a patch to configure.ac, to add "-lrt" to LIBS when needed.
> > 
> > Yes, definitely... that's why I posted the message :).
> 
> 
> Sorry I can't be of more help, I'm probably as (or more) confused by the
> situation as you are.

Any reason why we don't use pkg-config for finding out these
dependencies?



More information about the Gdb mailing list