Proposal: Drop GDB support for Python versions < 2.6

Eli Zaretskii eliz@gnu.org
Thu Feb 21 03:40:00 GMT 2019


> From: Paul Smith <psmith@gnu.org>
> Date: Wed, 20 Feb 2019 16:29:35 -0500
> 
> On Wed, 2019-02-20 at 13:45 -0700, Kevin Buettner wrote:
> > Going even further, since 2.6 is no longer supported by the Python
> > community, I'd also be okay with saying that GDB only supports Python
> > 2.7 and Python 3.X.
> 
> Don't know if anyone cares, but as a heavy user of Python support in
> GDB, I'm fine with this.  As long as GDB still supports Python 2.7 it's
> A-OK with me.

Not with me, though.  I still use Python 2.6.x for reasons unrelated
to GDB, and would like to avoid installing one more version just to
compile GDB.  So please leave Python 2.6 supported if it's reasonably
possible.



More information about the Gdb mailing list