Proposal: Drop GDB support for Python versions < 2.6

Paul Koning paulkoning@comcast.net
Wed Feb 20 22:06:00 GMT 2019



> On Feb 20, 2019, at 4:29 PM, Paul Smith <psmith@gnu.org> wrote:
> 
> On Wed, 2019-02-20 at 13:45 -0700, Kevin Buettner wrote:
>> Going even further, since 2.6 is no longer supported by the Python
>> community, I'd also be okay with saying that GDB only supports Python
>> 2.7 and Python 3.X.
> 
> Don't know if anyone cares, but as a heavy user of Python support in
> GDB, I'm fine with this.  As long as GDB still supports Python 2.7 it's
> A-OK with me.

I concur.

Along the same lines, do you want to drop support for <= 3.x for some x?  Python 3 is up to 3.7 now; I'm not sure if it matters much to the code or maintenance burden, but dropping support for some of the older 3.x releases might also make sense.

	paul



More information about the Gdb mailing list