Proposal: Drop GDB support for Python versions < 2.6

Joel Sherrill joel@rtems.org
Wed Feb 20 21:49:00 GMT 2019


On Wed, Feb 20, 2019, 3:45 PM Jan Vrany <jan.vrany@fit.cvut.cz wrote:

> On Wed, 2019-02-20 at 16:29 -0500, Paul Smith wrote:
> > On Wed, 2019-02-20 at 13:45 -0700, Kevin Buettner wrote:
> > > Going even further, since 2.6 is no longer supported by the Python
> > > community, I'd also be okay with saying that GDB only supports Python
> > > 2.7 and Python 3.X.
> >
> > Don't know if anyone cares, but as a heavy user of Python support in
> > GDB, I'm fine with this.  As long as GDB still supports Python 2.7 it's
> > A-OK with me.
>
> As for myself, as another user of python support, fine with me.
>
> Actually, I'd even be fine with more radical move, dropping support
> for 2.x altogether. Python 2.7 support will end in less a year
> from now anyway.
>

Python 2.7 is shipping with at least one long-term support distribution.
While it is unlikely that anyone will notice on the native side, I know we
(RTEMS) build recent, hopefully the latest, gdb version cross.

--joel


> Just my two cents.
>
> Jan
>
>



More information about the Gdb mailing list