Obsoleting Solaris 10 support

Rainer Orth ro@CeBiTec.Uni-Bielefeld.DE
Wed Oct 17 12:42:00 GMT 2018


Hi Dennis,

> On 10/16/2018 05:42 AM, Rainer Orth wrote:
>> Yesterday I've announced the obsoletion of Solaris 10 support in GCC 9
>>
>> 	https://gcc.gnu.org/ml/gcc/2018-10/msg00139.html
>>
>> I believe the same reasons cited there hold for GDB as well.  Besides,
>> we had some build failures recently that only occured on Solaris 10,
>> creating work to support a rapidly dwindling or even vanished user base.
>> Therefore, I wonder how best to handle this in GDB.
>>
>
> Looking at the gcc test results for the past few years it looks like
> efforts have fallen off a cliff. Certainly I have lost a lot of
> interest. I still have reasons to work with Apache and OpenSSL and a
> few other places but even those reasons are going away.
[...]

one reason for that may well be that Oracle has started integrating
reasonably recent versions of gcc (and gdb) into Solaris 11, so the need
for others to do the work has diminished.

> There was considerable activity in the previous five years and I know
> that I have been submitting results as far back as 1999 or so. However
> the last five years clearly point the direction.

Right: it was way different when all you had was the gcc 3.4 in Solaris
10 or some version and Studio cc and go from there yourself ;-)

	Rainer

-- 
-----------------------------------------------------------------------------
Rainer Orth, Center for Biotechnology, Bielefeld University



More information about the Gdb mailing list