Obsoleting Solaris 10 support

Rainer Orth ro@CeBiTec.Uni-Bielefeld.DE
Wed Oct 17 12:34:00 GMT 2018


Hi Joel,

>> this would argue for an obsoletion in the GDB 8.4 timeframe, roughly at
>> the same time GCC itself does.  Issues I'm facing with Solaris 10 right
>> now (apart from the S10-only build breakages) are having to deal with
>> different syscall numbers while working on an xml syscall table for
>> Solaris and catch syscall support, as well as differences in corefile
>> contents.  I suspect there will be more as time goes on.
>
> Sound good. Feel free to step in and make suggestions if you have
> new info that makes you think we should stop support earlier.

I guess 8.4 should be fine.  I've just checked the last couple of
releases which suggest that 8.3 will be ready sometime next spring,
close to the gcc 9 release.  In that case, obsoletion/removal in gdb 8.4
is just fine.  Initially I'd misremembered that gdb followed a procedure
similar to gcc (obsoletion in one release, removal in the next), but the
two being almost one step isn't a problem either.

	Rainer

-- 
-----------------------------------------------------------------------------
Rainer Orth, Center for Biotechnology, Bielefeld University



More information about the Gdb mailing list