Issue with Latest GDB on AIX with GCC-6.12

Pedro Alves palves@redhat.com
Wed Feb 8 12:06:00 GMT 2017


On 02/08/2017 06:16 AM, Nitish Kumar Mishra wrote:

> I tried adding try/catch block earlier in throw_it and
> throw_exception_cxx functions
> but got no significant results.
> I had tried adding try catch block in these functions:
> kill_command
> command_handler
> command_line_handler
> execute_command
> throw_it
> throw_exception_cxx,
> but no progress. Output is exactly same as we got earlier (Other than
> extra frames for new
> try catch functions). None of the print statements in catch blocks for
> above functions worked.

Eh, it sounds like _no_ exception catching works then?  I just
confirmed now that at least on GNU/Linux, GDB does not throw any 
exception internally during startup.  This backtrace in question may
well not be special at all, and may be that _all_ exception catching
is broken.  I'd try experimenting with simple things like:

try
{
  throw 1;
}
catch (...)
{
   printf (....);
}

right at the start of gdb's main().  Not in a separately
compiled test program, but really inside gdb, to avoid
differences in how gdb vs the test program is built.

It could also be that this is only triggered due to
GDB's binary size, hence not triggered in a small program -- I
recall that there was some trouble with the size of some sessions
and the linker in the AIX 7.1 box couldn't link gdb, or something
like that?  Maybe that's not fully/correctly sorted out.

Thanks,
Pedro Alves



More information about the Gdb mailing list