internal-error inferior_thread(): Assertion `tp' failed

Luke Dalessandro ldalessandro@gmail.com
Thu Apr 20 17:17:00 GMT 2017


> On Apr 20, 2017, at 1:04 PM, Simon Marchi <simon.marchi@polymtl.ca> wrote:
> 
> I have just tried building Valgrind, and it runs fine for me with Valgrind-3.13.0.SVN.  Some more data points:
> 
> 1. g++/libstdc++/libc version?  And which distro/version, that might be easier.
> 2. Does it still happen if you start gdb with -nx (to avoid loading any custom configuration)?
> 
> Simon

I opened a bug for this https://sourceware.org/bugzilla/show_bug.cgi?id=21405.

1. gcc is 6.3
2. valgrind is svn(r16308) configured with `--enable-ubsan --with-mpicc=mpicc`
3. distribution is Ubuntu 14.04.5 LTS
4. -nx has no apparent impact

$ ldd hello
	linux-vdso.so.1 =>  (0x00007ffc6f5db000)
	libstdc++.so.6 => /u/ldalessa/.local/gcc/gcc-6.3/lib64/libstdc++.so.6 (0x00007fc89b245000)
	libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007fc89af3f000)
	libgcc_s.so.1 => /u/ldalessa/.local/gcc/gcc-6.3/lib64/libgcc_s.so.1 (0x00007fc89ad28000)
	libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007fc89ab0a000)
	libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007fc89a742000)
	/lib64/ld-linux-x86-64.so.2 (0x00007fc89b5c3000)




More information about the Gdb mailing list