gdb on macOS 10.12 "Sierra"

Jason Molenda
Mon Oct 31 23:24:00 GMT 2016

Hi Jonas, there was a change in macOS 10.12.1 that may be impacting gdb.  After an exec, you need to refresh the task port that gdb uses in its mach calls.  You can see the lldb change here:


-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: patch.txt
URL: <>
-------------- next part --------------

I skimmed this email thread and someone said that disabling launch-with-shell worked around the issue.  That would be in line with this OS change.


> On Oct 31, 2016, at 4:54 AM, Jonas Maebe <> wrote:
> Tristan Gingold wrote:
>>> On 01 Oct 2016, at 14:08, Jonas Maebe <> wrote:
>>> Has anyone succeeded yet in getting gdb to work on macOS 10.12? Reportedly, it works when you disable SIP (which is understandable, given ), but plain code signing no longer seems to cut it.
>> No, I haven't tried yet.  Did you investigate if lldb has updated its build instructions ?
> I finally got time to look into this. lldb's codesigning instructions
> are at
> .
> They have not been updated recently, but they do differ from gdb's.
> However, the result is exactly the same: SIG113.
> I've also asked on the darwin-dev@apple list, but did not get any
> replies there.
> ...
> I've now tried building lldb, and regardless of whether I use the GDB or
> LLDB-style codesigning certificate to sign debugserver (lldb itself does
> not need codesigning), it works. So it seems like the problem is not
> necessarily related to codesigning per se.
> Jonas

More information about the Gdb mailing list