Removing support for LinuxThreads and vendor 2.4 kernels w/ backported NPTL

Pedro Alves palves@redhat.com
Fri Dec 11 00:24:00 GMT 2015


As a funny coincidence, while trying to fix PR threads/19354,
I stumbled on workarounds for LinuxThreads...

So I went ahead and wrote a patch to not only make use of
__WALL, but yank out support for ancient LinuxThreads and vendor
2.4 kernels w/ backported NPTL:

  https://sourceware.org/ml/gdb-patches/2015-12/msg00214.html

So ... FYI.

Thanks,
Pedro Alves



More information about the Gdb mailing list