GDB on ARM

Senthil Kumar Selvaraj senthil_kumar.selvaraj@atmel.com
Thu Mar 27 07:03:00 GMT 2014


On Thu, Mar 27, 2014 at 11:17:20AM +0530, Ashoka K wrote:
> Hi,
> 
> I am trying to use Valgrind on ARM target. The Valgrind intrenally
> supports GDB. To connect to the Valgrind-GDB (i.e, gdbserver) i need
> the GDB (host) also to run on arm target. i.e GDB and GDServer both
> built with host=arm-linux-gnueabi.
> 
> I downloaded latest GDB7.7 and able to build gdbserver, but during
> building GDB with host=arm-linux-gnueabi I got the below error. I
> searched all over and found that to install libncurses package. I did
> that but it didn't work.
> 
> My system:
> Build-host: Ubuntu-Lucid (10.04) on Virtual-machine with
> arm-linux-gnueabi tool chain
> Target: ARM OMAP
> 
> checking for library containing gethostbyname... none required
> checking for library containing socketpair... none required
> checking for library containing zlibVersion... no
> checking for library containing dlgetmodinfo... no
> checking for iconv... yes
> checking for iconv declaration... install-shextern size_t iconv
> (iconv_t cd, char * *inbuf, size_t *inbytesleft, char * *outbuf,
> size_t *outbytesleft);
> checking for library containing waddstr... no
> configure: WARNING: no enhanced curses library found; disabling TUI
> checking for library containing tgetent... no
> configure: error: no termcap library found

You can check the config.log file to see the exact command line used by
configure to detect the presence of libtermcap.

Regards
Senthil



More information about the Gdb mailing list