'Cannot find bounds of current function' when stepping with GDB 7.6 under OS X 10.6 / LLVM GCC 4.2

eranon eric.anon@laposte.net
Fri Feb 7 20:00:00 GMT 2014


No luck ! I've tried, rebuilding both the DEBUG build of my project and the
underlying static wxWidgets DEBUG build too, adding "-Wl,-no_compact_unwind"
(without quotes) in the IDE's linker options for my project and in the
LDFLAGS for wxWidgets (building it from command line)... And same result :(

Here is a typical gdb session showing the concerned behavior :

Breakpoint 1, MyApp::OnInit (this=0x8010a00) at MyApp.cpp:162
162	    wxApp::SetAppName("MyApp");
(gdb) n
0x00ab2a34 in ?? ()
(gdb) n
Cannot find bounds of current function
(gdb) 

So, did I missed a point ? What can I do other ?
And for the other way, using full FSF GCC/GDB, not tried yet. But I'll do
it.



--
View this message in context: http://sourceware-org.1504.n7.nabble.com/Cannot-find-bounds-of-current-function-when-stepping-with-GDB-7-6-under-OS-X-10-6-LLVM-GCC-4-2-tp259756p260325.html
Sent from the Sourceware - gdb list mailing list archive at Nabble.com.



More information about the Gdb mailing list