'Cannot find bounds of current function' when stepping with GDB 7.6 under OS X 10.6 / LLVM GCC 4.2

Tristan Gingold gingold@adacore.com
Thu Feb 6 15:31:00 GMT 2014


On 06 Feb 2014, at 16:10, eranon <eric.anon@laposte.net> wrote:

> What I get could look like what expressed in this thread : 
> http://sourceware-org.1504.n7.nabble.com/gdb-can-not-debug-hello-world-in-mac-os-x-td107600.html
> 
> In addition to the error I told about, at the same time, hitting the "n"
> command, I get something like this too :
> 
> (gdb) n 
> 0x00003045 in ?? ()
> 
> So, the question is maybe : What FSF gdb version should I use to debug a
> i386 DEBUG build coming from the LLVM GCC 4.2 shipped with Xcode 4.2 under
> OS X 10.6 (and I have OS X 10.8 with Xcode 4.6 too, but didn't installed my
> dev environment in full under this station yet) ?

I am almost sure that FSF gdb doesn't support binaries produced by recent version of
LLVM shipped by xcode.  They use compact unwinding, which isn't handled by gdb.
This is on my todo list, but not that urgent because FSF gcc doesn't emit them (it
passes -no_compact_unwind to ld).



More information about the Gdb mailing list