'Cannot find bounds of current function' when stepping with GDB 7.6 under OS X 10.6 / LLVM GCC 4.2

eranon eric.anon@laposte.net
Wed Feb 5 12:24:00 GMT 2014


Hello. I'm porting a wxWidgets-based app towards Mac. For this, my dev
station is under OS X 10.6 Snow Leopard with the Xcode 4.2 tools (but I'm
using Codeblocks as IDE). I built wxWidgets 3.0.0 and my own project using
the Apple flavor of GCC (aka. LLVM GCC 4.2), indicating arch i386. My
problem is about debugging : to be able to plug a pretty printer for seeing
the wxWidgets structure (e.g. wxString), I need a Python-enabled gdb, and
the one provided by Apple in the Xcode tools is not. So, I've taken a try
with FSF gdb 7.6 as per http://sourceware.org/gdb/wiki/BuildingOnDarwin, but
I experience the impossibility to go step by step. Not talking about IDE,
but launching gdb from the command line, the first breakpoint is honored,
but using the "n" command to execute one step at a time, I get this error :
"cannot find bounds of current function". Since the Apple gdb is still under
/usr/bin/, I call the FSF gdb 7.6 with its absolute path (tried with an
in-place use and with make install under /usr/local/bin and it give the same
result/error). Of course, at this step not any pretty printer Python script
is involved (it will be the next stage if I solve my current issue). I tried
to rebuild my project passing an explicit "-ggdb" option rather than the
implicit "-g", but it doesn't change anything (same error during stepping).
So, what to do ? Do you have an idea about the reason why ? Is it because of
incompatible debug info, an issue about arch, a too big gap between the LLVM
GCC 4.2 and FSF GDB 7.6... ? I need your lighted advice for sure...



--
View this message in context: http://sourceware-org.1504.n7.nabble.com/Cannot-find-bounds-of-current-function-when-stepping-with-GDB-7-6-under-OS-X-10-6-LLVM-GCC-4-2-tp259756.html
Sent from the Sourceware - gdb list mailing list archive at Nabble.com.



More information about the Gdb mailing list